1
Fork 0
nixos-system-config/flake.nix
caem 654cde2a3a
Add KDE and set it as the default on the workstation host
Note: The kde configuration is currently incomplete. It's still missing
some configuration using the plasma-manager flake. I'm going to get
plasma working first and then worry about the small configuration
details.
2024-08-28 18:21:04 +02:00

49 lines
1.1 KiB
Nix

{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
nur.url = "github:nix-community/NUR";
impermanence.url = "github:nix-community/impermanence";
home-manager = {
url = "github:nix-community/home-manager";
inputs.nixpkgs.follows = "nixpkgs";
};
plasma-manager = {
url = "github:nix-community/plasma-manager";
inputs.nixpkgs.follows = "nixpkgs";
inputs.home-manager.follows = "home-manager";
};
};
outputs = {
nixpkgs,
impermanence,
home-manager,
nur,
plasma-manager,
...
} @ inputs: let
lib = nixpkgs.lib.extend (final: prev:
import ./lib { lib = final; }
);
in {
nixosConfigurations = lib.mkHosts {
modules = [
home-manager.nixosModules.home-manager {
home-manager.sharedModules = [
nur.hmModules.nur
plasma-manager.homeManagerModules.plasma-manager
];
}
impermanence.nixosModules.impermanence
nur.nixosModules.nur
];
nixpkgs = nixpkgs;
inputs = inputs;
};
};
}