1
Fork 0
nixos-system-config/home/default.nix
caem af0078d7af
Refactor configuration to be more modular.
TODO: Update the documentation in the README to reflect changes
2024-08-26 15:01:33 +02:00

26 lines
446 B
Nix

{ config, ... }:
{
users.users.hu = {
isNormalUser = true;
extraGroups = [ "wheel" ];
hashedPasswordFile = "/nix/config/secrets/pass";
};
home-manager = {
useGlobalPkgs = true;
useUserPackages = true;
users.hu = {
home.username = "hu";
home.homeDirectory = "/home/hu";
home.stateVersion = config.system.stateVersion;
xdg.enable = true;
};
};
imports = [
./persist.nix
];
}