1
Fork 0
nixos-system-config/lib/fs.nix
caem 1ea937f884
Refactor: Initial step
- Added library for common functions
- Moved machines/ to hosts/
- Automise adding new hosts to the flake
2024-07-25 21:24:28 +02:00

10 lines
175 B
Nix

{ lib }:
{
getDirsInDir =
path: let
dirs = builtins.readDir path;
in
builtins.filter (name: dirs.${name} == "directory") (builtins.attrNames dirs);
}